
LA PSEUDO 3D AVEC GIMP
Par André Pascual

I  n  t  r  o  d  u  c  t  i  o  n

Gimp est un logiciel exclusivement 2D,mais avec un peu de ruse,grâce aux nombreux outils dont il dispose, il
est possible de créer une image en pseudo 3D.

          Pour parvenir au résultat comme celui là, quatre étapes sont nécessaires :

1. Créer un fond avec effet de perspective pour le sol
2. Créer un texte avec effet de loupe sur le mur vertical
3. Créer une pseudo−sphère réfléchissante
4. Peaufiner en ajoutant des ombres et des reflets spéculaires et de lentille.
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LA PSEUDO 3D AVEC GIMP
Par André Pascual

E  t  a  p  e   1 :

Créer le fond / Choisir le motif
On supposera que le motif "circuit" est disponible dans Gimp. Si ce n'est pas le cas, n'importe quel autre motif (dont la liste, dans
Gimp, apparaît en cliquant sur <File><Dialogs><Patterns> ou en tapant [Shift+ Ctrl+ P] ) fera l'affaire. Dans cette liste, cliquer sur
une vignette a pour effet de produire son affichage en taille 1:1 sous le curseur et d'indiquer le nom du motif que l'on vient ainsi
de sélectionner.

Si l'on veut reproduire exactement l'exemple proposé, et que le motif "circuit" n'existe pas dans Gimp, il faut le réaliser. Pour
cela, ouvrir Gimp, charger le fichier /opt/kde/share/wallpapers/circuit.jpg et le sauvegarder avec l'extension "pat", choisie dans la
liste des formats <By extension> de la boîte <Save Image>, tel que /usr/local/share/gimp/patterns/circuit.pat.

Ce motif sera disponible lors du prochain lancement de Gimp. Il est à noter que les chemins indiqués ici sont ceux de KDE 1.1.1
et de Gimp 1.0.4 installés sur une Mandrake 5.3; ils peuvent différer dans d'autres distributions.

Avant de commencer, rappelons que si l'on ignore la signification d'une icône de la boîte à outils, il suffit de laisser le pointeur
quelques instants sur l'icône en question pour voir apparaître une bulle d'aide. Rappelons également qu'un double−clic sur une
icône ouvre la boîte de dialogue <Tools options> spécifique à l'outil choisi. Rappelons encore qu'un clic−droit sur l'image en
cours ouvre les menus déroulants contenant tous les outils de manipulation, de la sauvegarde à l'édition en passant par les filtres
et autres Script−Fu... Et rappelons enfin que si la procédure qui suit fait référence au menus activés par la souris, toutes les
commandes citées peuvent être exécutées à l'aide de raccourcis dont certains sont habituels pour: nouveau, ouvrir, fermer,
quitter, copier, coller, couper, annuler, refaire...

Préparer les fonds
• Lancer Gimp, si ce n'est déjà fait.
• Préparer un fichier vide à l'aide de File> New> 640x480 >Background> OK
• Remplir le fond actuellement blanc par un double−clic sur Fill (pot de peinture)> Pattern Fill
• Ouvrir File> Dialogs >Patterns et choisir Circuit (ou autre chose)
• Cliquer dans la fenêtre de travail.

C'est fait.
Comme il faudra une image pour le mur et une pour le sol, sauvegarder le travail en jpeg quality 1.00 (sans compression; on
compressera l'image finale) d'abord en 1.jpg, puis de nouveau sous 2.jpg. On dispose alors de deux images identiques, 1.jpg et
2.jpg, l'image 2 étant affichée à l'écran. Elle va servir à créer le sol. Voir Figure 2 :
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LA PSEUDO 3D AVEC GIMP
Par André Pascual

E  t  a  p  e   2 :

Créer le fond / Créer le sol
L'image finale aura une dimension de 400x400 (choix arbitraire). On peut donc déformer 2.jpg, actuellement à l'écran et qui est
bien plus grande (640x480), en s'aidant des guides magnétiques. Ceux−ci sont dissimulés dans les règles bordant l'image. Il
suffit pour cela de cliquer sur un règle et, en maintenant enfoncé le bouton gauche de la souris, de déplacer le pointeur sur la
zone de travail pour voir une ligne pointillée rouge se déplacer, horizontalement ou verticalement selon la règle sur laquelle on a
cliqué. En relâchant la pression sur le bouton, on dépose la ligne à l'endroit voulu. Un index se déplaçant sur la règle en même
temps que la ligne aide à sa dépose à une distance précise de l'origine (indiquée en pixels; 1 graduation= 10 pixels). Cette ligne
pointillée devient bleue lorsqu'elle est désélectionnée: il s'agit d'un guide magnétique lequel attirera le pointeur de la souris, ou le
bord d'une sélection, lorsqu'on s'en approchera.

• Placer de la sorte un guide horizontal à 300 pixels de l'origine, puis deux guides horizontaux, l'un à 120 et l'autre à 520.
• Sélectionner le calque par un clic−droit sur l'image et Select> Select all
• Double−cliquer sur Transform Layer or Sélection (dans la boîte à outils). Dans la boîte <Tools options> qui apparaît

choisir <Perspective>
• Déformer la sélection pour obtenir un trapèze en faisant coïncider le coin haut/gauche de la sélection avec l'intersection

gauche des guides. Attention : opération gourmande en calculs et donc en temps. Attendre qu'elle soit terminée avant
de cliquer n'importe où.

• Amener ensuite le coin haut/droite à l'intersection droite des guides. On obtient alors un trapèze isocèle (Voir Figure 3)

Icônifier l'image ou l'expédier vers un autre bureau. Par précaution, on peut même la sauvegarder.
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LA PSEUDO 3D AVEC GIMP
Par André Pascual

E  t  a  p  e   3 :

Créer le fond / Créer le mur frontal
• Rappeler l'image 1.jpg
• Placer un guide horizontal à 400 pixels, et deux verticaux, l'un à 120 et l'autre à 520.
• Sélectionner le calque par clic−droit> Select >Select all
• Sélectionner Transform Layer or Selection et, dans <Tool option> qui est en principe ouverte de l'appel précédent,

choisir Scaling.
• Déformer le calque de sorte qu'il occupe le carré de 400x400 délimité par les guides.
• Ajouter maintenant un calque transparent par clic−droit> Layers> Layers et channels >New layer (l'icône à gauche de la

boîte de gestion des calques qui vient de s'ouvrir). On va positionner le sol sur ce calque, alors autant l"appeler "sol" en
cliquant sur le nom par défaut "new layer". Voir Figure 4 :
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LA PSEUDO 3D AVEC GIMP
Par André Pascual

E  t  a  p  e   4 :

Créer le fond / Assembler mur et sol
• Copier le sol trapézoïdal de 2.jpg dans le presse−papier (utiliser l'outil plume, cliquer à chaque sommet du trapèze,

terminer en cliquant sur le point de départ puis à l'intérieur du trapèze pour valider)
• Le coller dans 1.jpg, sur le calque "sol" que l'on vient de créer, par clic−droit> Edit >Paste Le sol se pose sur le calque

vide. Le mettre en place de sorte que le bord inférieur de la sélection coïncide avec le guide horizontal.(Voir Figure 5)

• Aplatir l'image par clic−droit> Layers> Flatten image. Celle−ci ne comporte plus alors qu'un seul calque.
• Découper l'image pour une dimension de 400x400 avec l'outil Crop de la boîte à outil (il se colle automatiquement aux

guides magnétiques)
• Ajouter un calque "Texte"

Sauvegarder (juste par sécurité) sous 3.XCF (format de Gimp conservant les calques, choisi dans la liste des formats <By
extension>.)
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LA PSEUDO 3D AVEC GIMP
Par André Pascual

E  t  a  p  e   5 :

Créer le texte / Produire un texte−logo
• Cliquer sur Xtns> Script−Fu> Logos> Crystal
• Entrer le texte "LOUPE" (ou autre chose), Font "Cooper" (ou autre), Font size "105", Background

"/opt/kde/share/wallpapers/circuit.jpg", OK.
Nota: la police "Cooper" fait partie du paquetage "Freefont" et n'est pas installée par défaut sur toutes les distributions.
On aura grand intérêt à se procurer ce paquetage, ainsi que le paquetage "Sharefont" qui sont quasiment
indispensables pour une typographie des plus agréables. (101 polices vectorielles disponibles auprès de Christoph
Lameter, <clameter@waterf.org>.

• Le logo est produit; les lettres sont texturées avec le même motif que le mur mais de taille supérieure puisque le mur,
lui, a été réduit. On obtient ainsi un effet de loupe.

• Le logo est constitué de plusieurs calques, dont un appelé "Background". Celui−ci n'ayant plus d'utilité, il faut le
supprimer par clic−droit> Layers> Layers & channels> Delete layer (l'icône croix, à droite), le calque à supprimer étant
sélectionné. On le selectionne en cliquant sur sa vignette: il doit se trouver alors dans une surbrillance bleue.

• Assembler les calques restants par clic−droit> Layers> Merge Visible Layer (sourtout pas Flatten image: on perdrait la
transparence du fond) (Voir Figure 6)
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LA PSEUDO 3D AVEC GIMP
Par André Pascual

E  t  a  p  e   6 :

Créer le texte / Assembler le texte
• Copier le texte dans le presse−papier
• Le coller dans 3.XCF (qui n'a pas été fermé) sur le calque "Texte"
• Le positionner à la demande (ce qui est sensé être vu par transparence devra correspondre plus ou moins avec le

dessin du mur qui se trouve derrière. Voir Figure 7).

Sauver sous 3.XCF (nécessaire cette fois−ci, car il va falloir maintenant triturer le dessin affiché à l'écran sans toutefois
perdre ce que l'on vient de faire)
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LA PSEUDO 3D AVEC GIMP
Par André Pascual

E  t  a  p  e   7 :

Créer la sphère réfléchissante / Préparer le reflet
La sphère doit réfléchir le texte appliqué au mur frontal, c'est à dire que celui−ci doit apparaître inversé par rapport à l'original, et
incurvé sur la sphère.

• Sélectionner le texte par une sélection rectangulaire, le calque "Texte" étant la calque actif
• Sélectionner l'outil symétrie verticale par double−clic sur Flip layer or selection> Vertical (Flip layer se trouve dans la

boîte à outils)
• Désigner la sélection à déplacer avec le curseur qui est pour l'occasion remplacé par une double flèche haut/bas

Dessiner la sphère proprement dite

Maintenant, c'est plus délicat. 

− Aplatir l'image par clic−droit >Layers>
Flatten image 

− Effectuer une sélection circulaire (appuyer
sur Shift en même que la souris se déplace
afin d'obtenir un cercle et non une ellipse),
de telle sorte que 3 lettres au moins soient
concernées par la sélection et qu'elles se
situent dans la partie supérieure du cercle.

− Déformer la sélection par clic−droit>
Filters> Distorts> Whirl and Pinch avec les
valeurs suivantes: "whirlangle:0", "Pinch
amount:−1", "Radius:2" (ce sont des valeurs
choisies en fonction du résultat désiré et
obtenues par plusieurs essais: il n'y a pas de
formule dans ce domaine) 

− Valider et recommencer l'opération, avec
le mêmes valeurs (Voir Figure 8) 

La sélection étant toujours active, la copier dans le presse papier. On peut maintenant fermer le dessin en cours sans
sauvegarder.
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LA PSEUDO 3D AVEC GIMP
Par André Pascual

E  t  a  p  e   8 :

Assembler sphère et décor
• Rappeler le fichier 3.XCF
• Créer un calque "sphère"
• Coller la sphère et la positionner (voire changer son échelle) pour que les lettres réfléchies correspondent aux lettres du

mur.
• Sauvegarder sous 3.XCF

Peaufiner l'ouvrage
C'est la partie du travail qui reflète le plus la sensibilité, ainsi que le doigté, du créateur. Aussi ne donnerai−je que des conseils
généraux afin que la créativité de chacun s'exprime. Faisons un constat pour continuer: les lettres du logo "LOUPE" reçoivent un
éclairage horizontal venant du côté gauche de l'image (observer les ombres). La sphère doit donc être logiquement éclairée de la
même manière; en conséquence, elle doit projeter sur le sol une ombre résultant de cet éclairage, et avoir une portion de sa
surface dans l'ombre. 

Créer une ombre sur la sphère
• Ajouter un calque "ombre sphère", transparent opacity 90 (il y a toujours possibilité de revenir sur cette valeur), mode

de mélange "Normal"
• Placer 4 guides magnétiques tangents à la sphère.
• Effectuer une sélection circulaire à l'aide des guides (partir de l'intersection haut/gauche jusqu'à l'intersection

bas/droite). La sélection doit circonvenir la sphère.
• Double−clic sur l'outil Fill with a color gardient; dans la boîte <Tool options> choisir "Blend: FG to transparent" et

"Gradient: Linear".
• Sélectionner une couleur noire si ce n'est déjà fait
• Emplir la sélection circulaire d'un dégradé de noir−>transparent en traçant une horizontale qui part de l'extrémité droite

du diamètre de la sphère à son extrémité gauche (il faut imaginer le diamètre: il n'est pas représenté).

L'ombre est posée. Faites des essais avec les modes de mélange du calque "ombre sphère", afin de voir comment se
comportent les pixels noirs de ce calque avec ceux qui se trouvent sur les calques de dessous.
Sauver le travail quand vous êtes satisfait.
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LA PSEUDO 3D AVEC GIMP
Par André Pascual

E  t  a  p  e   9 :

Créer l'ombre portée sur le sol
♦ Ajouter un calque "ombre sol", transparent, opacity 80
♦ Imaginer la forme de cette ombre: il s'agit d'une ellipse assez aplatie. Pour l'obtenir, tracer une sélection

elliptique (sans appuyer sur ) et la positionner de telle sorte que l'extrémité gauche de son grand axe
(horizontal ici) coïncide avec le point de contact sphère/sol. On peut s'aider de guides magnétiques pour cela
(Voir Figure9)

♦ Double−clic sur l'outil Fill with a color or pattern; dans la boîte <Tool options> choisir "Mode: Normal" et "Fill
Type: Color fill".

♦ Choisir un vert très sombre (R:18, G:35, B:14 par exemple)
♦ Emplir la sélection de ce vert.
♦ L'ombre résultante n'est pas réaliste parce que trop nette en périphérie. Une ombre réelle est toujours plus

diffuse sur les bords. On va tenter de l'obtenir en deux temps:
♦ La sélection étant toujours active, clic−droit > Filters> Blur> Motion Blur> Radial avec les valeurs "Lengh: 35"

et "Angle: 45"> OK

Désélectionner, puis double−clic> Filters> Blur> Gaussian Blur (RLE) avec les valeurs par défaut > OK
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LA PSEUDO 3D AVEC GIMP
Par André Pascual

E  t  a  p  e   10 :

Créer un reflet spéculaire à la sphère
La lumière venant de gauche, toute la bordure gauche de la sphère doit être plus lumineuse.

♦ Ajouter un calque "reflet"
♦ Effectuer une sélection assez large en forme de croissant avec la plume (plus difficile au lasso) de la bordure

gauche de la sphère.
♦ Sélectionner une couleur blanche
♦ La peindre en dégradé FG−>Transparent par la même méthode que précédemment, mais de gauche à droite.
♦ Mélanger les calques en mode "overlay". Si l'effet n'est pas assez prononcé, peindre deux à trois fois de la

même manière.

Créer un effet de lentille
La lumière frappant la sphère est projetée dans l'objectif de l'appareil sensé photographier la scène, produisant ainsi
une aberration optique, appelée "Lens flare".

♦ Aplatir l'image
♦ Placer deux guides magnétiques afin que leur intersection correspondent avec le centre du reflet (Voir Figure

1), et relever sur les règles leur position en X et Y
♦ Double−clic >Filters> Light Effects> Flare FX
♦ Entrer les valeurs relevées en X et Y au paramètre "Center of Flare FX". On peut également déplacer à la

souris le curseur sur la vignette de l'image et positionner ainsi visuellement le centre du reflet.

La dernière touche
On peut encore fignoler en ajoutant quelques points de lumière grâce à double−clic> Filters> Light Effects> Super Nova
avec des paramètres tels que Radius 2 ou 3 et Spoke 50 sur les lettres de verres proches du trajet lumineux. Quant aux
couleurs de ces points, c'est affaire de goût.

Conclusion
Voilà. L'oeuvre est presque terminée. J'écris presque parce qu'en regardant bien dans les coins, il doit sûrement
subsister des défauts, des approximations... Tout créateur ne pourra en détacher son regard et il n'aura de cesse, grâce
à ses recettes personnelles, que de les gommer autant que faire se peut.

Que chacun s'y amuse.

Car Linux, plus Gimp, plus l'envie de créer, est une source d'amusement à ne pas négliger.

Copyright : André Pascual

Contacter l'auteur : André Pascual
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